Android Wallet 1.1.9 Cant Backup Seed

Hi Everyone,

I havent used Waves platform for a little while. But when I did the latest Waves wallet app version was 1.1.9. I transferred my coins from the exchange and left it. Now my android device is old so it doesnt allow me to upgrade the client. Its running Android 4.4.2 version with Kernel version 3.4.0.

Whenever I open Waves wallet app I get a notification about no internet(but the internet works fine on the device with other apps) but with Waves wallet nothing works. I cant send my coins or I cant backup the seed. When I open the app i get following message:
“Waves Wallet cannot obtain an internet connection. Please check the connectivity on your device and try again.”

When i try to backup the seed i get follow message and the app just quits abruptly.

“Secure connection to the host has failed. This might indicate malicious activity. Please verify network connection and device before continuing”

Any help is much appreciated. I tried connecting with VPN, and clearing the cache for the app but nothing worked.

Android wallet is opensource. Just download source code (the same version you have on device) and debug it

Hi Brox,

Can you please explain/expand on your idea.


What do you mean by ‘backup seed’? Didn’t you write 15 seed words in the safe place? If yes - you don’t need android app to recover your coins. If no - you have to learn basics of android development. Again, weight the efforts - does it worth to recover coins cost?