Problem node no generate, commands and solutions

As a title, I think I have problems.
My node has no 15-day blocks, normally a block every 1-5 days.
What could it be?
Is it possible that it still is normal?

What do you see in your logs? Are there any error messages?

1 Like

Still no block in sight.
I visited again, my logs.
No error.
I have updated packages and restarted.
Everything is OK.
I have investigated some nodes, some do not have blocks for 15 days, some nodes I can not see the blocks, some nodes with lower budget than I have blocks almost every day, the nodes at the top of course are untouchable.
What’s wrong?

Did you check if you are not on a fork?

For this I need explanations

Check if your node is here and what the status is:

111 ScudoNode DE EU-DIGITALOCEAN-L1 Digital Ocean, Inc. 0.15.4 open - - -

Yes I know this site, I go there often, very simple useful and interesting.

You are on node version 15.4 (which is forked I think).

Install 15.5 and resync the blockchain.

It seemed to you…
Ok now I’m running.

Done, as soon as we update, let’s see.

Now how long is it to wait to see blocks again?

Not seeing signs I destroyed the knot and I rebuilt it from scratch.
When will I be able to see it?

*Check if the node is running and syncing the last blocks with:

journalctl -u waves.service -f

Now we also see in dev.pywaves.
It is 5 hours and 30 minutes that it is synchronizing.
How much is still needed?

First not synced, which means that it was synchronizing.
Now forked at 1033312
What it means?
The node has synchronized to that height?
Or do I still have to worry about the anomalous forked node?

Like I said what does the log say when you issue the journalctl -u waves.service -f command?

1 Like

Now it seems synchronized.
The registry tells me nothing.
The question is after using journalctl -u waves.service -f, to me it never worked, the terminal seems to stop and you never see anything.
Since I have the knot, I have always had to wait for it to see in dev.pywaves, and to see them is synchronized.
However misery are already 2 days for synchronization?

I do not know what to say, the node of new not synced.
DigitalOcean sent me a message saying they have network connectivity problems and my droplet may be affected.
I guess that until they solve, I will not be able to come up with it myself.

Nobody is able to give me other suggestions?

Here you can download a recent valid state from wavesplatform site:

I use on the fly downloading + unpacking (stop waves and rm -r your data dir):

wget -qO- | tar xv -C /your/waves/dir/with/data/dir

The syncing from the genesis is a pain.

1 Like