TestNet Technical Issue

Mates, i am having some issue with trying to run the address on TestNet explorer, it says the provided API key is not correct. What can i do to rectify this?

What exactly have you tried to do?

I had the same issue with faucet for testing, it’s ok now - just checked.

Yes, the faucet has not worked because of scripted account on the node. Now, it spends money from other account.

I have tried it twice on different browsers and i got the same error message stating the Personal API address is not correct. This has really halted my learning progress. What do you advice?

May be it’s because we have changed the api-key for official testnet nodes? Yes, we did it because those nodes are for us only :slight_smile:
If this is your case I encourage you to install your own testnet node. It’s quite straightforward process.

Okay, can you send me the link for the nodes download?

It’s on GitHub https://github.com/wavesplatform/Waves/releases/tag/v0.13.4

i have downloaded the link, but i don’t know how to use it, can you kindly help please?